forum My links still aren't working
Started by @Purple-Cat location_cityThe Worldbuilder
tune

people_alt 63 followers

@Purple-Cat location_cityThe Worldbuilder

Hi @andrew

I hope I'm not bothering you, but my links haven't been working lately, when I try to put a link in a text field it doesn't save and deletes anything I've written with it, it's gone on for a while now.

@Eldest-God-andrew health_and_safety flash_onAdmin

Hey again! Still looking into this, but I can't seem to replicate the issue. Can I get a little more information for you to help me diagnose why you're seeing what you are?

  1. What browser are you using? (Chrome, Firefox, Internet Explorer, etc)
  2. What operating system are you using? (Windows, Mac, iPhone, Android, etc)
  3. When you press @ in a text field, do you see the list of pages to link to? It should look like this:

  4. After you've typed and/or added your link, do you see the autosaving notice at the top-right of your screen? It should look like this:

  5. If you don't see the autosave banner, does it show up if you click into another field (other than the one you wrote in)? If so, do things start to properly save for you?
  6. Just to clarify, when you say you "put a link in a text field it doesn't save and deletes anything I've written with it", do you mean it deletes everything in the field (including things you've previously added and saved), or just doesn't save the changes you've written while adding that link? Or does clicking on the link just delete everything in the field immediately?

  7. If you press F12 (if you're on a computer, not a phone) and click the "Console" tab after adding a link, are there any displayed lines other than "Keyboard shortcuts are enabled/disabled on this page"? Errors will be in a bright red text. It should look like this:

  8. If you log into your account with an Incognito window or from another device, does everything still (not) work the same way?

If links are deleting your text, there's definitely something weird going on. These questions should help me pinpoint what exactly that could be. My working hunch right now is that it's either a browser incompatibility issue and/or some browser extension causing problems, but obviously that makes it hard for me to find the culprit from my own browser. I'll keep looking, though! We can't have you trying to worldbuild without links! Thanks for any additional info you can provide here.

@Purple-Cat location_cityThe Worldbuilder

I use safari on Mac, MacBook, iPad and iPhone, the problem is the same on all of them.

The list does come up but when I select something the auto-save notice isn't there and doesn't appear when I select another field either. But does appear when I type in the text field normally, but only when I click another field or the 'view this page' feature does it actually come up.

What I mean is that it doesn't save what I've written at the time, but anything I've written beforehand is still there.

I tried the F12 thing and nothing happened, I don’t know if I’m doing it wrong or not but it just turned my volume up which is what it normally does, the photos you attached aren’t visible, they’re just tiny blue boxes with question marks to me.

And I don’t think I have access to an incognito windows, as you put it.

@Eldest-God-andrew health_and_safety flash_onAdmin

Interesting! Thank you for the info. I'll have to hunt down a Mac to try Safari on.

A couple quick follow-up questions for you:

  • Are you on a public or school network that might be managing traffic or blocking sites (for example, the background autosaving)? It's odd that the images are just blue boxes with question marks – that typically means something isn't loading properly, and whatever's causing it on images might also be affecting the autosave.

  • Do you have any kind of adblocker installed? We don't run any ads, but ad blockers have broken a lot of stuff for a lot of users recently and that's probably worth just double-checking in case this is another instance.

  • Have your fields ever saved correctly after adding a link to text?

It's alright F12 didn't work, that's a Chrome feature (although it's probably somewhere in Safari, I just don't know how it works). Same with incognito windows. You gave me enough to do some more investigation though!

And, just to clarify on how the autosave works, it only autosaves when your browser loses focus of a field (for example, clicking into another field, navigating to another page, or closing the tab). The latter (closing the tab) probably doesn't always work in Safari and might need fixed somehow, even when just typing normally, but clicking outside of a field (or into any other field) should definitely be triggering the autosave. It seems like something is going wrong in Safari when you select a link, which is blocking autosave code from running afterwards.

I'll do some testing. Thanks again for the info!

@Purple-Cat location_cityThe Worldbuilder

To answer your questions, I don’t think it’s the network, since it acts that way wherever I am, no matter what connection I’m on. I’ve tried saving images in my documents before, and they’re there for a short time, maybe the first time I view it? I’m not sure since it’s been a long time since I added a photo in documents and haven't needed to for a while. But then the images turn to tiny blue boxes.

And for the record, my gallery images are fine, this just happens in documents. I didn’t really see it as a problem before since I assumed that documents are just more compatible with text than images.

I don’t have any adblockers installed.

And my links and text have always saved before, this problem is only a couple weeks or so old.

@Eldest-God-andrew health_and_safety flash_onAdmin

Hey there! Just wanted to reach out and say I'm still investigating here. I haven't found a way to cause the issue on my end yet (even saving temporary changes to a couple of your pages from Safari on a Mac – I undid the changes immediately after!). I still have a few more routes to investigate through, but just didn't want to leave you with complete radio silence. Thanks again for the details!

@Eldest-God-andrew health_and_safety flash_onAdmin

Quick update: I just pushed out a few updates that might help with this, and I had another release a few days ago that might've also helped. I also have another release going live tonight that may fix things also. Since I haven't been able to replicate the bug on my end, it's hard to say for certain whether any of these will actually fix the problem you're seeing, but I worked on things that would logically help and I'm hoping they do. Thanks again for all the info.