forum @ links are not working, please help
Started by @Purple-Cat location_cityThe Worldbuilder
tune

people_alt 67 followers

@Purple-Cat location_cityThe Worldbuilder

I’ve had this issue for a while now. When I use the @ link feature it does not save and doesn’t save anything else I typed with it. A couple days ago it worked and saved properly once when I decided to test it after a long time of not using it. Because of this I thought the issue was fixed but when I went to try it again it didn’t save and hasn’t worked again since.

@Eldest-God-andrew health_and_safety flash_onAdmin

Hey @Purple-Cat, thanks for letting me know about this. Does this happen on all of your pages, or just some? Would you mind letting me know what browser you're using where it's not saving? Also, when you select a page in the @ link menu, does it insert the [[Page-123]]-looking code (and then not save that), or does it just insert nothing at all?

Happy to dig into this and get it sorted out; any extra info you can provide to help me reproduce the issue is much appreciated! :)

@Purple-Cat location_cityThe Worldbuilder

It happens on all pages
I primarily use safari, i haven’t tried it on other browsers though
It does insert the code and then doesn’t save it. The ‘saving…’ message doesn’t appear either.
I hope this helps!

@Eldest-God-andrew health_and_safety flash_onAdmin

Hey there, just wanted to follow up on this. I had a hard time replicating the issue on my end, but I put out a small release last night that could potentially fix the issue, and I have a bigger update going out tonight (edit: tomorrow!) that includes a few other tweaks that make linking a little more robust. I hope one of these two fixes should help out, but please do let me know if you're still experiencing issues tomorrow (I'll also update here when the release is live).

Either way, I'll keep investigating and see if I can figure out what might be causing it until I've heard it's fixed. I thought for sure it would be some kind of local browser setting and/or extension interacting with the site (we've had a lot of problems with ad blockers, for example), but that seems far less likely if you're seeing the issue across multiple browsers.

Just wanted to give a quick update. Trying to fix this quickly, thanks again for the heads up about this!

@Eldest-God-andrew health_and_safety flash_onAdmin

Hey @Purple-Cat, thanks for following up.

I've pushed out a couple releases since that I had hoped would fix it, but I'm still having trouble replicating the issue on my side (even when manually editing your pages to test) so it's hard to determine whether any particular fix will solve it for sure.

Can I ask a couple other questions and/or get a little more diagnostic info from you? It'd help a ton in trying to figure out where the problem's coming from so I can suggest a fix.

  • I know you said it's happening in all browsers, so I don't think it's a conflict with any browser or extension in those browsers (unless you have the same extensions in every browser). Do you have any other devices that you can test from? It's possible some sort of antivirus or network setting on the computer might be blocking the background saves in some circumstances.

  • Would it be possible for you to open a browser console and see if any error show up when you try to link a page and the autosave fails? You can do this by pressing F12 (or Option + ⌘ + C in Safari on a Mac) or right-clicking on the page and selecting "Inspect", then clicking the "Console" tab at the top. Once that's open, can you then try to link a page and see if any errors show up there? It should also be noted that autosave specifically triggers when your cursor leaves any field, so clicking outside of the field after you're done typing is what should explicitly trigger it (and trigger any related errors also).

The console should look like this (or similar in e.g. Safari):

When there's an error, you'll see additional messages with either a yellow (warning) or red (error) background. If you see any, could you either copy and paste or screenshot them to share with me? If the link code is being inserted into the field, Javascript should still be running in your browser, but if that field is then not autosaving, something could be crashing Javascript and stopping it from running.

  • Finally, could I also get a little extra info on whether you're using a VPN or proxy? It's very unlikely but a VPN might have some security feature that's preventing the autosave from completing as well. It might be grasping at straws, but it'd be nice to knock out all the possibilities so I can get this sorted out for good for you.

Thanks for any other help you can provide, I'll do some more research on what could possibly be going wrong and jump back on this to hopefully find a fix soon.

@Purple-Cat location_cityThe Worldbuilder

Hi Andrew, I’ve tried it on a few other devices. My main device I use is an IPad Pro but I’ve tried it on a Mac and iPhone.

On the Mac the list that comes up when you press the @ symbol didn’t show up at all. On the IPad and IPhone the list did show up but didn’t save anything as usual.

I’m afraid couldn’t find how to open a browser console, I tried what you said but it didn’t work. Sorry about that.